Simple BGP Multi-home Topology Part 0 – LAB info

Here is some information about the lab I’ve been using to study and to share all the information. You can used them for your own testing purposes and tweak what you like.

I’ve used GNS3 on my MACBOOK PRO Mid 2010 equipped with 128Gb Kingston SSD (not the best choice) and 8Gb RAM.
It allows me to setup and configure about 6 to 8 3725 routers with 128Mb RAM assigned without getting my CPU temperature above 82 degrees Celcius :-\

For all routers I’ve used IOS 12.4(25)d Advanced IP Services for platform 3725. To improve power up speed I’ve unpacked the IOS software.

You can use a baseconfig.txt to ensure you always have the correct base configuration for logging purposes and other stuff. I haven’t used it until I got fed up with mistyping and waiting for ip domain-lookup to finally finish searching for a hole in the time-space continüum. Which he never found {bummer}!

!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
service sequence-numbers
!
!
logging buffered 80000 debugging
logging console notifications
!
no aaa new-model
memory-size iomem 5
ip cef
!         
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd
!
!
no ip http server
ip http access-class 2
ip http authentication local
no ip http secure-server
!
!
line con 0
 exec-timeout 15 0
line aux 0
line vty 0 4
 exec-timeout 5 0
 login
 transport input telnet
line vty 5 15
 exec-timeout 5 0
 login
 transport input telnet
!
end

Here are all the configurations so far:

Router CUSTOMER

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CUSTOMER
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback2
 ip address 1.1.1.2 255.255.255.255
!
interface Loopback101
 ip address 192.168.1.1 255.255.255.0
!
interface Loopback102
 ip address 192.168.2.1 255.255.255.0
!
interface Loopback103
 ip address 192.168.3.1 255.255.255.0
!
interface Loopback104
 ip address 192.168.4.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.16.1.2 255.255.255.254
 speed 100
 full-duplex
!
interface FastEthernet0/1
 ip address 172.16.1.4 255.255.255.254
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 33.10.20.3 255.255.255.254
 speed 100
 full-duplex
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 10.10.10.11
 log-adjacency-changes
 redistribute bgp 64200
 network 192.168.1.0 0.0.0.255 area 100
 network 192.168.2.0 0.0.0.255 area 100
 network 192.168.3.0 0.0.0.255 area 100
 network 192.168.4.0 0.0.0.255 area 100
 neighbor 33.10.20.2
!
router bgp 64200
 no synchronization
 bgp log-neighbor-changes
 aggregate-address 192.168.0.0 255.255.0.0 suppress-map SUPRESS-MAP-INTERNAL
 redistribute ospf 1 route-map CHANGE-ORIGIN
 neighbor 3.3.3.3 remote-as 64310
 neighbor 3.3.3.3 description *** ISP1 ***
 neighbor 3.3.3.3 ebgp-multihop 255
 neighbor 3.3.3.3 update-source Loopback1
 neighbor 3.3.3.3 distribute-list 90 in
 neighbor 3.3.3.3 route-map LOCAL-PREF-INTERNET-AS64310 in
 neighbor 4.4.4.4 remote-as 64510
 neighbor 4.4.4.4 description *** ISP2 ***
 neighbor 4.4.4.4 ebgp-multihop 2
 neighbor 4.4.4.4 update-source Loopback2
 neighbor 4.4.4.4 distribute-list 91 in
 neighbor 4.4.4.4 route-map LOCAL-PREF-INTERNET-AS64510 in
 no auto-summary
!
ip forward-protocol nd
ip route 3.3.3.3 255.255.255.255 172.16.1.3 name BGP_NEIGH_ISP1
ip route 4.4.4.4 255.255.255.255 172.16.1.5 name BGP_NEIGH_ISP2
ip route 10.10.10.10 255.255.255.255 33.10.20.2
!
ip as-path access-list 1 deny 64510
ip as-path access-list 1 permit .*
ip as-path access-list 2 deny 64310
ip as-path access-list 2 permit .*
!
ip http server
no ip http secure-server
!
ip access-list standard INTERNAL-NETWORKS
 permit 192.168.1.0
 permit 192.168.2.0
 permit 192.168.3.0
 permit 192.168.4.0
ip access-list standard INTERNET-LP-SET
 permit 10.1.1.0
!
!
ip prefix-list SUPPRESS-PREFIX seq 10 permit 192.168.1.0/24
ip prefix-list SUPPRESS-PREFIX seq 20 permit 192.168.2.0/24
ip prefix-list SUPPRESS-PREFIX seq 30 permit 192.168.3.0/24
ip prefix-list SUPPRESS-PREFIX seq 40 permit 192.168.4.0/24
access-list 60 permit any
access-list 90 permit 10.1.1.0
access-list 90 permit 193.31.9.0
access-list 90 permit 193.31.1.0
access-list 91 permit 10.1.1.0
access-list 91 permit 193.51.1.0
access-list 91 permit 193.51.9.0
!
route-map SUPRESS-MAP-INTERNAL permit 10
 match ip address prefix-list SUPPRESS-PREFIX
!
route-map CHANGE-ORIGIN permit 10
 match ip address 60
 set origin igp
!
route-map BLOCK-AS64510 permit 10
 match as-path 1
!
route-map BLOCK-AS64310 permit 10
 match as-path 2
!
route-map LOCAL-PREF-INTERNET-AS64310 permit 10
 match ip address INTERNET-LP-SET
 set local-preference 120
!
route-map LOCAL-PREF-INTERNET-AS64310 permit 20
!
route-map LOCAL-PREF-INTERNET-AS64510 permit 10
 match ip address INTERNET-LP-SET
 set local-preference 400
!
route-map LOCAL-PREF-INTERNET-AS64510 permit 20
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Router ISP1

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Loopback100
 ip address 193.31.1.1 255.255.255.224
!
interface Loopback200
 ip address 193.31.2.1 255.255.255.224
!
interface Loopback300
 ip address 193.31.3.1 255.255.255.224
!
interface Loopback400
 ip address 193.31.4.1 255.255.255.224
!
interface Loopback500
 ip address 193.31.5.1 255.255.255.224
!
interface Loopback600
 ip address 193.31.6.1 255.255.255.224
!
interface Loopback700
 ip address 193.31.7.1 255.255.255.224
!
interface Loopback800
 ip address 193.31.8.1 255.255.255.224
!
interface Loopback900
 ip address 193.31.9.1 255.255.255.224
!
interface FastEthernet0/0
 ip address 172.16.1.3 255.255.255.254
 speed 100
 full-duplex
!
interface FastEthernet0/1
 ip address 172.18.1.2 255.255.255.254
 duplex auto
 speed auto
!
router bgp 64310
 no synchronization
 bgp log-neighbor-changes
 network 193.31.1.0 mask 255.255.255.224
 network 193.31.2.0 mask 255.255.255.224
 network 193.31.3.0 mask 255.255.255.224
 network 193.31.4.0 mask 255.255.255.224
 network 193.31.5.0 mask 255.255.255.224
 network 193.31.6.0 mask 255.255.255.224
 network 193.31.7.0 mask 255.255.255.224
 network 193.31.8.0 mask 255.255.255.224
 network 193.31.9.0 mask 255.255.255.224
 neighbor 1.1.1.1 remote-as 64200
 neighbor 1.1.1.1 ebgp-multihop 2
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 5.5.5.1 remote-as 64100
 neighbor 5.5.5.1 ebgp-multihop 2
 neighbor 5.5.5.1 update-source Loopback0
 no auto-summary
!
ip forward-protocol nd
ip route 1.1.1.1 255.255.255.255 172.16.1.2 name BGP_NEIGH_CUST1
ip route 5.5.5.1 255.255.255.255 172.18.1.3
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Router ISP2

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface Loopback100
 ip address 193.51.1.1 255.255.255.224
!
interface Loopback200
 ip address 193.51.2.1 255.255.255.224
!
interface Loopback300
 ip address 193.51.3.1 255.255.255.224
!
interface Loopback400
 ip address 193.51.4.1 255.255.255.224
!
interface Loopback500
 ip address 193.51.5.1 255.255.255.224
!
interface Loopback600
 ip address 193.51.6.1 255.255.255.224
!
interface Loopback700
 ip address 193.51.7.1 255.255.255.224
!
interface Loopback800
 ip address 193.51.8.1 255.255.255.224
!
interface Loopback900
 ip address 193.51.9.1 255.255.255.224
!
interface FastEthernet0/0
 ip address 172.18.1.4 255.255.255.254
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.16.1.5 255.255.255.254
 duplex auto
 speed auto
!
router bgp 64510
 no synchronization
 bgp log-neighbor-changes
 network 193.51.1.0 mask 255.255.255.224
 network 193.51.2.0 mask 255.255.255.224
 network 193.51.3.0 mask 255.255.255.224
 network 193.51.4.0 mask 255.255.255.224
 network 193.51.5.0 mask 255.255.255.224
 network 193.51.6.0 mask 255.255.255.224
 network 193.51.7.0 mask 255.255.255.224
 network 193.51.8.0 mask 255.255.255.224
 network 193.51.9.0 mask 255.255.255.224
 neighbor 1.1.1.2 remote-as 64200
 neighbor 1.1.1.2 ebgp-multihop 2
 neighbor 1.1.1.2 update-source Loopback0
 neighbor 5.5.5.2 remote-as 64100
 neighbor 5.5.5.2 ebgp-multihop 2
 neighbor 5.5.5.2 update-source Loopback0
 no auto-summary
!
ip forward-protocol nd
ip route 1.1.1.2 255.255.255.255 172.16.1.4 name BGP_NEIGH_CUST2
ip route 5.5.5.2 255.255.255.255 172.18.1.5
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Router INTERNET

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname INTERNET
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
interface Loopback1
 ip address 5.5.5.1 255.255.255.255
!
interface Loopback2
 ip address 5.5.5.2 255.255.255.255
!
interface Loopback100
 ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.18.1.5 255.255.255.254
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.18.1.3 255.255.255.254
 duplex auto
 speed auto
!
router bgp 64100
 no synchronization
 bgp log-neighbor-changes
 network 10.1.1.0 mask 255.255.255.0
 redistribute connected
 neighbor 3.3.3.3 remote-as 64310
 neighbor 3.3.3.3 ebgp-multihop 2
 neighbor 3.3.3.3 update-source Loopback1
 neighbor 4.4.4.4 remote-as 64510
 neighbor 4.4.4.4 ebgp-multihop 2
 neighbor 4.4.4.4 update-source Loopback2
 no auto-summary
!
ip forward-protocol nd
ip route 3.3.3.3 255.255.255.255 172.18.1.2
ip route 4.4.4.4 255.255.255.255 172.18.1.4
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s